How to Unlock Bootloader on Any Android Phones Using Fastboot

Home Forums Common to All Forum (Generic Topics) Common How-To Guides How to Unlock Bootloader on Any Android Phones Using Fastboot

This topic contains 18 replies, has 9 voices, and was last updated by  shibaa987 5 days, 14 hours ago.

Viewing 9 posts - 11 through 19 (of 19 total)
  • Author
    Posts
  • #11684

    shibaa987
    Keymaster

    One of the output of the following command: fastboot oem device-info
    (bootloader) Device unlocked: true

    Which tells the bootloader is unlocked.

    #11685

    shibaa987
    Keymaster

    Yes, it is completely possible that after unlocking the bootloader data might not be wiped. It all depends on the OEMs the way they lock the bootloader. Many of the OEMs do not unlock the bootloader at all.

    Now for the TWRP installation part, here goes another step-by-step guide that explains: how to install TWRP recovery on an Android phone.

    #11687

    shibaa987
    Keymaster

    The command window waits at “waiting device”, when the device is not yet recognized by the system.

    It is possible that you might have connected the device to the PC but either of the following is causing a problem:

    1. Either Android debugging is not enabled
    2. If Debugging is Enabled, check if OEM unlock is enabled in Developer Options

      This guide explains how to enable USB debugging and OEM unlocking

    3. Finally, if everything is enabled, then check if you have given permission for the system to use ADB

    When debugging is enabled and the device is connected to a system, it may ask for a permission on the phone to allow the ADB access to the system. Please verify all and let me know if you have enabled everything and still it does not work.

    #24262

    Jiri Prchal
    Participant

    Hi,
    I’ve got ZTE nx512j and I’m trying unlocking bootloader for a while, tryed everything, but doesn’t work, oem unlock enabled:

    [email protected]:~/phone/zte_z9_max$ adb reboot bootloader
    [email protected]:~/phone/zte_z9_max$ sudo fastboot -i 0x19d2 oem unlock

    FAILED (remote: oem unlock is not allowed)
    finished. total time: 0.001s
    [email protected]:~/phone/zte_z9_max$ sudo fastboot -i 0x19d2 oem device-info

    (bootloader) Device tampered: false
    (bootloader) Device unlocked: false
    (bootloader) Charger screen enabled: false
    (bootloader) Display panel:
    OKAY [ 0.004s]
    finished. total time: 0.004s

    Please help.

    #24270

    Jiri Prchal
    Participant

    So after a while I got over this issue. I used just command
    “sudo fastboot -i 0x19d2 flash recovery twrp-3.1.1-1-nx512j.img”
    and after reboot TWRP started.
    But I have another problem: the system partition is too small to fit lineage and gapps-nano, there is missing only 3MB. Pico goes well, but is very limited. Is there any possibility to resize partitions?

    #24326

    Ronit Verma
    Participant

    I am not able to unlock my phones’s bootloader. when I enter the command $ fastboot oem unlock an error is displayed. the error is : The term ‘$’ is not recognized as the name of a cmdlet, function, script file, or operable program. Check the
    spelling of the name, or if a path was included, verify that the path is correct and try again.
    what to do now ?

    Attachments:
    #24360

    shibaa987
    Keymaster

    The term ‘$’ is not recognized as the name of a cmdlet, function, script file, or operable program. Check the
    spelling of the name, or if a path was included, verify that the path is correct and try again.

    You need to remove the $ from the command that you are executing.
    Execute only the following:
    fastboot oem unlock

    #24585

    Ronit Verma
    Participant

    now it is giving the following error….
    unknown oem command

    #25259

    shibaa987
    Keymaster

    now it is giving the following error….
    unknown oem command

    Can you tell on which phone are you trying to unlock the bootloader by the way ??

Viewing 9 posts - 11 through 19 (of 19 total)

You must be logged in to reply to this topic.

 
 

One Comment